Después de realizar algunas instalaciones nuevas de Windows Server 2016 con clientes RDS con Windows 10 nos hemos percatado que algunos clientes de escritorio remoto arrojan un error al querer conectarse al servidor haciendo mención del siguiente error:

Error de autenticación:
No se permite la función solicitada

Equipo remoto: xxx.xxx.xxx.xxx
Puede deberse a una actualización de Oracle de Cifrado CredSSP
Para obtener más información, visita https: // go.microsoft.com / fwlink / ?linkid=866660

CredSSP Encryption Oracle Remediation

Actualización de Oracle de Cifrado CredSSP

Actualización de Oracle de Cifrado CredSSP

Para corregir este error hay dos soluciones, aplicar el update KB4093120 en el servidor y deshabilitar posteriormente las funciones de  «Oráculo de Cifrado» en las políticas de grupo, si no tenemos el update indicado esa opción no nos aparece en las políticas de grupo, por lo que hay que tenerlo en cuenta para no perder el tiempo o bien posterior a instalar el update en el servidor verificar si los clientes ya se pueden conectar, si ya se pueden conectar ya no es necesario hacer el movimiento.

Configuración de Equipos – Plantillas Administrativas -> Delegación de credenciales -> Correción de Oraculo de Cifrado
(Computer Configuration -> Administrative Templates -> System -> Credentials Delegation -> Encryption Oracle Remediation)

Authentication Error Function Not Supported CredSSP Error RDP

Error de Autenticación Función CredSSP en RDP

Si los clientes continúan con el problema se tiene que aplicar el update indicado KB4093120 para Windows 10 o bien para otras versiones el que se indica para actualización de Oraculo de Cifrado CredSSPO bien aunque no lo recomiendan ejecutar en cada cliente desde una ventana de CMD o PowerShell con privilegios de administrador lo siguiente:

REG ADD HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System\CredSSP\Parameters\ /v AllowEncryptionOracle /t REG_DWORD /d 2

De esa manera yo he conseguido solucionar el problemas en varios equipos que presentaban el error, cabe mencionar que aplicar el update desde nuestro servidor es una solución más rapida.

Categorías: PyME

Abrir chat
Hola! ¿En que te puedo ayudar?
Hola! :D ¿En que te puedo ayudar? Es un gusto para nosotros ser parte de tu solución.. :D